~xenrox/personal-packages

d53c6651f4297767d77a5442e05f6fe3c390375e — Thorben Günther 1 year, 6 months ago f06f2c6
builds.sr.ht: Add image rebuild timer
M builds.sr.ht/PKGBUILD => builds.sr.ht/PKGBUILD +8 -3
@@ 1,6 1,6 @@
pkgbase=builds.sr.ht
pkgname=(builds.sr.ht builds.sr.ht-images builds.sr.ht-worker)
pkgver=0.81.1
pkgver=0.82.9
pkgrel=1
arch=("x86_64")
license=("AGPL3")


@@ 11,12 11,16 @@ source=(
	"builds.sr.ht.service"
	"builds.sr.ht-worker.service"
	"builds.sr.ht-api.service"
    "builds.sr.ht-rebuild.service"
    "builds.sr.ht-rebuild.timer"
	"sysusers.conf"
)
sha256sums=('499c9e4727e79b504e85b35b0c95ceb8f0f6b307807b8d3a19270824e2cea67c'
sha256sums=('e41cfea34553be92851d9dacce6693d6615609c2f0d77a5ff59c0ee90fdee0ab'
            '95be67b46e8064376b8146a25780578250f53bf11bef790f95aae77e76a3fe22'
            'eee2c75cd45b7bf77eabe2687d4bb01ab3a66732977f01887a1d947d0a68c3d0'
            '50f4f9d6b32ff6482b6ca046721a48896a81a98a6c4fe2b8f3f0fc1884d21c2b'
            'e4e9f45d0ad6a6a0d058a2c43b79ca8692bccc043eec67de34d022ed673e9b87'
            '5acbfd596dcd4ad59774167a621fbab81c598acba8c9bf78a2b50bc632ad560f'
            '7d195dab1daa69ceb29c78eeae60b0fc332b255e96f33c01d5f906eaacaed541')
export PKGVER=$pkgver



@@ 34,7 38,6 @@ package_builds.sr.ht() {
	arch=("any")
	depends=(
		"python-srht"
		"python-pgpy"
		"python-celery"
		"python-redis"
		"python-yaml"


@@ 77,4 80,6 @@ package_builds.sr.ht-worker() {
	install -Dm755 worker/worker "$pkgdir"/usr/bin/builds.sr.ht-worker
	install -Dm644 ../builds.sr.ht-worker.service \
		-t "$pkgdir"/usr/lib/systemd/system/
	install -Dm0644 ../builds.sr.ht-rebuild.service -t "$pkgdir"/usr/lib/systemd/system/
	install -Dm0644 ../builds.sr.ht-rebuild.timer -t "$pkgdir"/usr/lib/systemd/system/
}

A builds.sr.ht/builds.sr.ht-rebuild.service => builds.sr.ht/builds.sr.ht-rebuild.service +8 -0
@@ 0,0 1,8 @@
[Unit]
Description=Rebuild Arch Linux image
After=network.target

[Service]
Type=oneshot
User=root
ExecStart=/usr/bin/builds.sr.ht/submit_image_build -n "Arch rebuild" -u "https://builds.xenrox.net" -p "/var/lib/images/builds" archlinux

A builds.sr.ht/builds.sr.ht-rebuild.timer => builds.sr.ht/builds.sr.ht-rebuild.timer +9 -0
@@ 0,0 1,9 @@
[Unit]
Description=Rebuild Arch Linux image timer

[Timer]
OnCalendar=*-*-* 09:00:00
Persistent=true

[Install]
WantedBy=timers.target