~xenrox/personal-packages

cb2ac08760dd62b0520bcc3f069d3c1009a0c0c6 — Thorben Günther 2 years ago 77d3dd2
Make namcap happy
2 files changed, 5 insertions(+), 5 deletions(-)

M README.md
M soju-srht/PKGBUILD
M README.md => README.md +1 -1
@@ 1,3 1,3 @@
[![builds.sr.ht status](https://builds.xenrox.net/~xenrox/personal-packages/commits/.build.yml.svg)](https://builds.xenrox.net/~xenrox/aur/commits/.build.yml?)
[![builds.sr.ht status](https://builds.xenrox.net/~xenrox/personal-packages/commits/.build.yml.svg)](https://builds.xenrox.net/~xenrox/personal-packages/commits/.build.yml?)

Personal Arch Linux packages.

M soju-srht/PKGBUILD => soju-srht/PKGBUILD +4 -4
@@ 13,9 13,9 @@ makedepends=('go' 'scdoc')
install=$_pkgname.install
provides=('soju')
conflicts=('soju')
githash="20525785cd2c45d0925bc0d9fdd62507d3400fef"
_githash="20525785cd2c45d0925bc0d9fdd62507d3400fef"
source=(
    "$pkgname-$pkgver.tar.gz::https://git.sr.ht/~emersion/soju/archive/$githash.tar.gz"
    "$pkgname-$pkgver.tar.gz::https://git.sr.ht/~emersion/soju/archive/$_githash.tar.gz"
    "soju.sysusers"
    "soju.service"
    "soju.tmpfiles"


@@ 28,7 28,7 @@ backup=('etc/soju/config')
validpgpkeys=('34FF9526CFEF0E97A340E2E40FDE7BE0E88F5E48')

build() {
    cd "$srcdir/$_pkgname-$githash"
    cd "$srcdir/$_pkgname-$_githash"
    export CGO_LDFLAGS="${LDFLAGS}"
    export CGO_CFLAGS="${CFLAGS}"
    export CGO_CPPFLAGS="${CPPFLAGS}"


@@ 42,7 42,7 @@ build() {
}

package() {
    cd "$srcdir/$_pkgname-$githash"
    cd "$srcdir/$_pkgname-$_githash"
    make PREFIX=/usr DESTDIR=$pkgdir install
    install -Dm644 "$srcdir/$_pkgname.sysusers" "$pkgdir/usr/lib/sysusers.d/$_pkgname.conf"
    install -Dm644 "$srcdir/$_pkgname.service" "$pkgdir/usr/lib/systemd/system/$_pkgname.service"